Support Articles/MasterCook FAQs/Printing & Publishing

Editing a Print Design

Pam Erickson
posted this on February 01, 2013 17:40

TOOLS TO BE USED WITHIN THE EDIT PRINT DESIGN SCREEN

Selected Object

When an object has been selected notice that the border is shaded gray, and that there are black squares on the sides. These squares indicate that you can resize the object by dragging the squares left or right. Note the thin dashed line around it to indicate its borders.

Not all objects can be resized, and not all objects can be resized in all directions. For the Ingredients, you can only resize its width. That is because the list of ingredients may be long or short, depending on the recipe. MasterCook will adjust the height as required.

In the Layout pane, MasterCook does not always show the complete contents of some items, for instance the Ingredients item. That is because the list will be different for each recipe. In the Layout pane, you are only concerned with the layout, not the content.

Guide Lines

Guide lines are vertical or horizontal red lines. They are used to help you line up objects – they are guides to the eye. You can add new ones by clicking with the right mouse button on an area of the Layout pane that is not covered by an object. Select the New Guide option in the popup menu. Guide lines are not printed.

Zoom

The Zoom drop down list gives you several options for zooming in or out on the Layout pane. If you need a close look, zoom in (large percentages).

Palette Button

The Palette button opens or closes the Publish Palette window. When you need to change a property of an object, select the item and open the Publish Palette window. There, you can change the font, font size, color and many other properties of the object.

If you have more than one object selected, the changes made in the Publish Palette window will apply to all the objects.

Print Preview Button

The Print Preview button opens a new window in which you can see what the print out will look like before you print it.

Print Sample Button

If you are getting ready to print many recipes and you want to make sure you have the layout just right, printing a sample will help you decide. The Print Sample button causes MasterCook to print just the recipe that is currently being viewed in the Layout window.

Print Original Selection

Clicking the Printer icon will cause MasterCook to print all the recipes that were selected when you started the Publish window.

Change Recipe Button

If you want to see what the layout looks like with a different recipe than the one shown, click the Change Recipe button to open a dialog in which you can pick a new recipe from those you originally selected to publish.

Splitter Bar

Drag the splitter bar left and right to change the relative size of the Layout and Preview panes.

Preview Pane

The Preview pane gives you quick feedback on what the changes you make will look like in the printed version.

You can adjust the size of the Preview pane by dragging the splitter bar between the Layout and Preview panes left and right.

The Publish/Print Right Click Menu

Right click the layout pane and this menu will appear. Several of the commands from the Design menu appear here too.

Zoom: You can view the layout pane in different magnifications: from 25% to 400%.

Grid: You can select a point size, the snap to grid command, or the show grid command.

Show Rulers: Select to hide or unhide the rulers.

Name: The name of the section in the layout. For example, title, notes and so forth.

Hide: Select this to hide a section.

Show All: Select this to unhide everything.

Group: Select this command to group objects into one. Once you’ve grouped objects two more commands will appear on the right click menu:

Ungroup: This command will ungroup the objects.

Lock Group: This will lock the grouped items into one object.

 

 

This example shows you how to edit a print design and paper selection with MasterCook.

1. START MasterCook.

2. SELECT Cookbooks from the navigation bar.

3. In the Cookbook Browser window OPEN a cookbook.

4. OPEN a recipe. (Apple-Oatmeal Crumb Cake in the Cooking Light '98 cookbook, for example.)

5. SELECT the Print/Publish button.

6. SELECT the Edit Design button in the Print/Publish window.

7. In the Edit Design window SELECT the Palette button.

NOTE: You can drag (select the title bar) this Palette window around the screen and out of your way. Be careful not to drag it off your screen totally and then forget about it. It is best to close it before leaving the Edit Design screen. Otherwise, when you come back later it may appear to be missing.

Creating a Custom Paper

NOTE: Does your printer come with a predefined 4x6 card? If so, try using it. Keep in mind some printers have trouble printing on these small cards. Check your printer's documentation.

8. SELECT the Page tab.

9. SELECT the Custom button to create a custom paper.

10. SELECT 3 Hole Paper from the "Name Paper" drop-down list so that all the fields below will be editable.

11. TYPE 6 for width, 4 for height. CHOOSE the minimum margins your printer supports. (For my Epson printer I choose 0.5 for all four sides.)

12. CHOOSE the Save As button to save your newly created "paper."

13. GIVE it a name. (I chose: Pam's 4x6 Index Card. See below.)

IndexCards01.gif

 

14. SELECT the OK button to close out of that Custom Paper window. Now we are back to the Edit Design window.

Editing the Design

15. In the Palette window SELECT the Avery #5389 design. (This is the design we are going to edit to create a new design.)

16. SELECT the Hide tab in the Palette window. Notice several recipe elements are hidden. (You want as little text as possible to fit on a small 4x6 index card.)

17. ADD checkmarks in the Hide tab for: Categories (I don't think I'll need these printed on an index card.), Alternate Time, Preparation Time, and Start to Finish Time (Usually the cooking time is listed in the directions of a recipe.)

18. SELECT Save Design As from the File menu to save changes so far w/o replacing the Avery #5389 design.

19. GIVE it a name. (I chose: Pam's 4x6 Index Card Design.)

20. RIGHT CLICK on the left half of the Edit Design screen (Print Layout) and CHOOSE to Zoom from the pop-up menu so you can see things easier to edit your design. See image below.

IndexCards03.gif

21. You may also want to CHOOSE Snap to Grid from the Design menu at the top and also CHANGE the Grid Spacing. (This will make working with a design easier.) If you choose "Show Rulers" from the Design menu you can adjust your "left column" more precisely, and the width of that column sets everything up for the right one.

22. SELECT the Recipe Title text box in the Print Layout and use the Text tab of the Palette to reduce the size of the font. (This large font is taking up wasted space.) I changed it to 12 point size.

TIP: I'd recommend you CHOOSE Save from the File menu often. That way if you do something you didn't mean to do, you can leave and choose to not save changes, and come back to where you left off.

23. SELECT the "No Text" text box in the Print Layout that is just above the Recipe Title. In the Object tab of the Palette you will notice this holds a border that produces a line across the top. See image below.

IndexCards04.gif

24. PRESS the Delete key on your keyboard to make this selected "No text" text box disappear. See image below.

IndexCards05.gif

25. SELECT the "No Author text" text box to highlight it. SCROLL the Print Layout to the left to see the resizing handles (black square box) to GRAB and drag the box narrower. (I made it about half the width of "Recipe Title" text box.) See image below.

IndexCards06.gif

From MC 6.0 Online Help:
[START]
Selected Object

This is an object that has been selected. In this case, it is the Ingredients recipe item. Notice that the border is shaded gray, and that there are black squares on the sides. These squares indicate that you can resize the object by dragging the squares left or right.

Not all objects can be resized, and not all objects can be resized in all directions. For the Ingredients, you can only resize its width. That is because the list of ingredients may be long or short, depending on the recipe. MasterCook will adjust the height as required.

In the Layout pane, MasterCook does not always show the complete contents of some items, for instance the Ingredients item. That is because the list will be different for each recipe. In the Layout pane, you are only concerned with the layout, not the content.
[END]

26. DO the same thing with the "Servings" text box.

27. DRAG the "Servings" text box up next to the "No Author text" text box. See image below.

IndexCards07.gif

28. DRAG the "Servings" text box to the far right edge and expand the "No Author text" text box by using the resizing handle. See image below.

IndexCards08.gif

29. SELECT the entire "ingredient" section, including the "(Your print out may include more ingredients...)"

30. GRAB the resizing handle on the right to make this box narrower. See image below.

IndexCards09.gif

31. SELECT the "Notes" section.

32. SELECT the Object tab in the Palette and notice there is a top border for this "Notes" text box. REMOVE this border by choosing the first square underneath Border Lines. See image below.

IndexCards10.gif

33. GRAB the resizing handle on the left side of the "Notes" text box and make it narrower. See image below.

IndexCards11.gif

34. DRAG the "Notes" text box up next to the "Ingredients" text box. See image below.

IndexCards12.gif

35. RESIZE the "No Yield text" text box to make it narrower.

36. DRAG it above the "Notes" text box. See image below.

IndexCards13.gif

37. RESIZE and then DRAG the "Serving Ideas text" text box up there, too. See image below.

IndexCards14.gif

38. Inside the "Directions" text box RIGHT CLICK on the big 'Recipe Picture' graphic box and choose hide.

39. SAVE your design.

Yay -- we're done!! Now we can do some further detailed work by zooming in even more and resizing these text boxes to align better. (I made the "Servings" text box right justification, etc.) See finished product below.

IndexCards16.gif

See image below for another example of the Page Preview with a different recipe.

IndexCards15.gif

Tips

When you try to drag a text box and it won't go and stay in the new location, keep in mind it DOES matter where the "in between" is (the space between other text boxes). Move one of the existing text boxes down just a bit to create more empty space. Then try dragging between the existing text boxes.

If you want the directions to have less space between the different direction steps (cells), put all the directions into the first cell only. You can do this very quickly and easily by exporting the recipe(s) as Text Only. Then import this file, and all the directions will only go into the first cell.

If you want to print on the backside of a single index card just insert one index card into your printer. When the printer beeps to insert more paper, just reinsert the card so that it will print on the backside. Be careful with the wet ink so it doesn't smear!

Lexmark Z51 printer:
NOTE: I have a Lexmark Z51 printer and need to feed cards in short side first.

Choose Pam's design and paper from the Print/Publish screen. Choose Landscape. Select the Edit Design button.

In Palette -- Page tab, make sure Pam's paper is chosen. Click Custom -- make sure Pam's paper is still chosen (it has flipped to "User Defined," courtesy of my printer, I think). Then edit so that Width = 4 and Height = 6. Adjust margins for your printer. Optimum margins for my printer turned out to be:

Left and Right = 0.25 inch
Top and Bottom = 0.5 inch

[I'm printing in Landscape, so the Left and Right margins are really the Top and Bottom of the card. The top margin is the edge that feeds out first (the left side of the card), and the bottom is the edge that feeds out last (the right side of the card.]

Then Save or Save As your paper design. Make sure Landscape is selected. Use Print Preview and the Print button from there, because it returns you to the Print/Publish page again (in 6.0) and you can re-check the design/paper settings again. When you leave the Print screen, save changes to design.

Download the Files

Attached below are the two files (Pam's 4x6 Index Card.mcp & Pam's 4x6 Index Card Design.mcd) that were created after the above steps. Feel free to download the ZIP file and use them for yourself.

Just place them inside the MC Tools folder, which is inside the MasterCook folder on your computer. Select Refresh File List from the Tools menu (or press the F5 key on your keyboard) while inside MasterCook to get it to show you these newly added files.

 

 
Topic is closed for comments